Namecheap and DNS is reporting issues
Incident Report for Engine Yard
Resolved
Update from Namecheap: We have successfully mitigated most of the DDoS attack and services are returning to normal. Services may be somewhat degraded while everything returns to normal over the next 60 minutes. Thank you for your understanding and patience during this difficult time.
Posted Feb 20, 2014 - 21:49 UTC
Monitoring
Namecheap's status page is back online and updates can be found here: http://status.namecheap.com/
Posted Feb 20, 2014 - 20:11 UTC
Identified
Namecheap is reporting issues with their site and DNS. For updates, visit their twitter page: https://twitter.com/Namecheap or https://twitter.com/Namecheap/status/436545372773974018 Please open a Support ticket if you are having issues.
Posted Feb 20, 2014 - 17:59 UTC