Installation failures for npm
Incident Report for Engine Yard
Resolved
The cert was rolled back by npm, which resolves the SSL errors faced earlier. If you have any further issues, please open a support ticket.
Posted Mar 02, 2014 - 20:22 UTC
Identified
The self-signed certificate for npm (Node.js Package Manager) is no longer valid, causing SSL errors for requests to https://registry.npmjs.org and affecting npm installations. We are aware of the issue and working on a permanent solution, in the meantime the issue can be bypassed by connecting to the relevant instances via SSH and running the command ' sudo /opt/nodejs/0.8.11/bin/node /usr/bin/npm config set ca "" ', then running an 'Apply' via the environment page of the Engine Yard dashboard to re-run the instance configuration.
Posted Feb 28, 2014 - 12:57 UTC