Trial Account Process
Incident Report for Engine Yard
Resolved
Trial signups should be working properly once more
Posted Apr 22, 2016 - 20:54 UTC
Investigating
We are currently seeing an issue with trial sign ups.
Posted Apr 22, 2016 - 19:59 UTC